New Project Dual Processor G4 (incomplete)

I inherited this particular poor, lost & unbootable PowerMac: this one is a 2000 model G4 Graphite Tower from a good friend of mine: Tom Crane at Crane Advertising.


The box doesn’t boot, I can press the power button hold it down–it just sits there like a brick should and a computer shouldn’t. I first tried removing the battery, clearing the PRAM and leaving the battery and it unplugged for days.

It could be one of three things: The Power Button (which I manually closed the gap on the jumpers as a Power Button would on the motherboard), the Logic Board or the Power Supply. My first instinct was the Power Supply. But a replacement Logic Board was MUCH more inexpensive.

I got the Logic Board in Yesterday and decided to replace it. Here’s my picture log of the electronic brain surgery.

I always loved how these cases opened up.


Here’s the reason why this power supply is so expensive to replace. The connector towards the end of the AGP card is actually a monitor power supply. This is powered by a set of two extra pins on the ATX connector feeding to the motherboard, which makes the Power Supply a fairly specialized item…. the rest of the components are pretty standard–ATA drives (which I plan on replacing), AGP graphics, PCI slots, USB, 1394, etc. This was a time when Apple wanted less cords for their computers. Eventually I suppose that this caused more headache than it was worth and they dropped this design in lieu of just a simple all-in-one LCD monitor like computer.


Preparing to remove the old Logic Board….


A few screws loose and the CPU Heat Sink and AGP card removed…


A pleasant surprise!!! It’s a dual-cpu machine!!!


A few of the Logic board screws removed and the CPU unit removed.


The bare metal case….


The trickiest part of this whole procedure was to set the cpu on board by carefully lining up the socket and gently pressing on it once was lined up perfectly.

After all this, it imitated a doorstop exactly the same as before, so it appears that it probably is a failed Power Supply. I’ve removed it from the case and I’ve taken it to work so that I can have David take a quick look at it and he agrees: it’s a dead Power Supply.

Oh well, good news is that I found a refurb for $80, and we’ll see how it works on the next installment!