MacPro installation of EVGA GeForce GTX 760

This is a visual guide for installation of an EVGA GeForce GTX 760 on a 2009 MacPro.

Just a note, I’ve already installed Mavericks on my Samsung 1TB SSD, but the tray from OWC hasn’t come in yet, so I’ve got it plugged into a SATA port in the Media bay for now – the drive in bay 4 is a 1TB standard platter drive for Time Machine.

IMG_1209

The most insane thing (not having the hardware in front of me) was going on faith that this whole deal would work. None of the photos online gave me clear pics of the power outputs on the motherboard — well, there they are – on the bottom left of the green. They’re pointed up, but they’re two min-six pin power points.

I already knew I needed a couple of adapters. Just run a search for MacPro PCI Express Video power adapters and get the 6, 4 or 8 pins you’ll need for your card. Mine required a 6 pin and an 8 pin. I think I spent $17 for both cables on a seller from Amazon.

IMG_1210 1

Here’s a photo of the ends that go into the motherboard….

IMG_1211

Just like this!

IMG_1212 1

 

Then remove the stock Video card…. anybody with PC tech won’t fret over this.

IMG_1213 1

Removal of second bay cover, and installation of GeForce PC Card…

IMG_1214

…then plugging them into the video card…
IMG_1215

Powered on, as I’ve read there’s no EFI boot displayed on a non-Mac card (that is, the dual tone gray apple logo boot screen), but once the OS loads up, BOOM. Pixel perfect.

IMG_1216 1

 

I installed the CUDA drivers and took Blender for a quick test spin…

Screenshot 2014-07-09 19.47.28

Not bad for a “free” (already purchased last year) upgrade.